Generic UI List Installation

First you need to install @generic-ui/ngx-list package with all it's peer dependencies. The best way to do that is with the help of NPM.

NPM installation:

$ npm i @generic-ui/ngx-list @generic-ui/fabric @generic-ui/hermes element-resize-detector@1.1.14

The alternative solution is to use yarn instead

yarn installation:

$ yarn add @generic-ui/ngx-list @generic-ui/fabric @generic-ui/hermes element-resize-detector@1.1.14

Make sure that you use Angular in version at least 8.0.0 and Rxjs in version greater than 6.0.0.



Download Angular List

Now your installation is completed. The list should be set and ready to use. To follow the basics of how to use list with the angular framework read this generic ui list basics guide.

The more advanced developers we suggest to read the List API documentation page.

Update

GenericUi's NPM / yarn install command will provide all of the needed code to run List in your Angular application. To keep List library updated and to have always newest version remember to run this script:

NPM update:

$ npm update @generic-ui/ngx-list @generic-ui/fabric @generic-ui/hermes

yarn update:

$ yarn upgrade @generic-ui/ngx-list @generic-ui/fabric @generic-ui/hermes







We use cookies to improve your experience. If you continue browsing, we assume that you consent to our use of cookies.